Bridge-UI Compilation error

tutorial
#1

I am following the setup instructions from : ERC20-to-ERC20 Bridge Deployment

The token bridge itself is running, however i encountered this issue with the bridge-ui. i setup the configuration to the different contracts, ran the sub module init, ran the npm install afterwards.

However when i do npm run start i get the following error message, i checked ou the contract folder, and it indeed does not exist. I double checked the npm install and i never see that contract being compiled either am i just missing something very obvious here ?


./src/stores/HomeStore.js
Module not found: Can't resolve '../contracts/RewardableValidators.json' in '/home/lorune/bridge-ui/src/stores'
0 Likes

#2

Hi! What Linux user are you using to perform the bridge UI deployment? The bridge UI configuration steps use npm scripts actively. And the npm documentation warns about running the npm scripts under the privileged account:

If npm was invoked with root privileges, then it will change the uid to the user account or uid specified by the user config, which defaults to nobody . Set the unsafe-perm flag to run scripts with root privileges.

So, in order to fix the issue either perform deployment actions under an unprivileged Linux account or use npm install --unsafe-perm.

0 Likes

#3

I am using Linux Mint (Ubuntu Bionic based).

The NPM install works fine, no errors at all, i tried with the parameter you mentioned and it remains the same issue. I’m quite stuck at this point with this issue.

This is the result of the NPM install:

The error on startup remains the same as i posted above (i seem to not be able to post more then 1 screenshot in a post…)

0 Likes

#4

Thanks for sharing. Btw, I’ve changed newuser_max_images option to 3 so you can post more images.
Alex will return back to you.

0 Likes

#5

We did few tests locally and cannot reproduce the issue.

Could you provide the following:

  1. the output of the npm install --loglevel verbose command.
  2. Run the following steps and provide the output:
  • cd submodules/poa-bridge-contracts
  • npm install --loglevel verbose
  • npm run compile --loglevel verbose
  • cd ../../
  • rm -r -f src/contracts
  • cp -r submodules/poa-bridge-contracts/build/contracts src/contracts
  1. If no errors appear on the step 2, try to run the bridge UI by npm run start.
1 Like

#6

Result of step 1 :

 lorune@lorune  ~/bridge-ui   master ●  npm install --loglevel verbose --scripts-prepend-node-path
npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'install',
npm verb cli   '--loglevel',
npm verb cli   'verbose',
npm verb cli   '--scripts-prepend-node-path' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb npm-session 3124e161164c04dd
npm info lifecycle bridge@0.1.0~preinstall: bridge@0.1.0
npm timing stage:loadCurrentTree Completed in 2823ms
npm timing stage:loadIdealTree:cloneCurrentTree Completed in 21ms
npm timing stage:loadIdealTree:loadShrinkwrap Completed in 1817ms
npm timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 2115ms
npm timing stage:loadIdealTree Completed in 4988ms
npm timing stage:generateActionsToTake Completed in 147ms
npm verb correctMkdir /home/lorune/.npm/_locks correctMkdir not in flight; initializing
npm verb lock using /home/lorune/.npm/_locks/staging-44ba3d034c0b15b6.lock for /home/lorune/bridge-ui/node_modules/.staging
npm timing audit compress Completed in 244ms
npm info audit Submitting payload of 129353bytes
npm timing action:extract Completed in 457ms
npm timing action:finalize Completed in 83ms
npm timing action:refresh-package-json Completed in 104ms
npm timing action:preinstall Completed in 1ms
npm timing action:build Completed in 2ms
npm timing action:install Completed in 1ms
npm timing action:postinstall Completed in 2ms
npm verb unlock done using /home/lorune/.npm/_locks/staging-44ba3d034c0b15b6.lock for /home/lorune/bridge-ui/node_modules/.staging
npm timing stage:executeActions Completed in 755ms
npm timing stage:rollbackFailedOptional Completed in 74ms
npm info linkStuff bridge@0.1.0
npm info lifecycle bridge@0.1.0~install: bridge@0.1.0
npm info lifecycle bridge@0.1.0~postinstall: bridge@0.1.0

> bridge@0.1.0 postinstall /home/lorune/bridge-ui
> cp lib/web3-eth/index.js node_modules/web3-eth/src && npm run compile:contracts

npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'run',
npm verb cli   'compile:contracts' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb run-script [ 'precompile:contracts',
npm verb run-script   'compile:contracts',
npm verb run-script   'postcompile:contracts' ]
npm info lifecycle bridge@0.1.0~precompile:contracts: bridge@0.1.0
npm info lifecycle bridge@0.1.0~compile:contracts: bridge@0.1.0

> bridge@0.1.0 compile:contracts /home/lorune/bridge-ui
> cd submodules/poa-bridge-contracts && npm install && npm run compile && cd ../../ && rm -r -f src/contracts && cp -r submodules/poa-bridge-contracts/build/contracts src/contracts

npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'install' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb npm-session e8bcc472a7048b05
npm info lifecycle poa-parity-bridge-contracts@1.0.0~preinstall: poa-parity-bridge-contracts@1.0.0
npm timing stage:loadCurrentTree Completed in 1388ms
npm timing stage:loadIdealTree:cloneCurrentTree Completed in 9ms
npm timing stage:loadIdealTree:loadShrinkwrap Completed in 672ms
npm timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 803ms
npm timing stage:loadIdealTree Completed in 1813ms
npm timing stage:generateActionsToTake Completed in 65ms
npm verb correctMkdir /home/lorune/.npm/_locks correctMkdir not in flight; initializing
npm verb lock using /home/lorune/.npm/_locks/staging-31a7e66af199bf61.lock for /home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.staging
npm timing audit compress Completed in 84ms
npm info audit Submitting payload of 53329bytes
npm timing action:extract Completed in 238ms
npm timing action:finalize Completed in 43ms
npm timing action:refresh-package-json Completed in 67ms
npm timing action:preinstall Completed in 0ms
npm timing action:build Completed in 1ms
npm timing action:install Completed in 0ms
npm timing action:postinstall Completed in 1ms
npm verb unlock done using /home/lorune/.npm/_locks/staging-31a7e66af199bf61.lock for /home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.staging
npm timing stage:executeActions Completed in 374ms
npm timing stage:rollbackFailedOptional Completed in 52ms
npm info linkStuff poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~install: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~postinstall: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~prepublish: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~prepare: poa-parity-bridge-contracts@1.0.0
npm timing stage:runTopLevelLifecycles Completed in 3964ms
npm verb saving []
npm verb shrinkwrap skipping write for package.json because there were no changes.
npm info lifecycle undefined~preshrinkwrap: undefined
npm info lifecycle undefined~shrinkwrap: undefined
npm timing audit submit Completed in 803ms
npm verb shrinkwrap skipping write for package-lock.json because there were no changes.
npm info lifecycle undefined~postshrinkwrap: undefined
npm WARN webpack-cli@2.0.13 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN poa-parity-bridge-contracts@1.0.0 No repository field.
npm WARN poa-parity-bridge-contracts@1.0.0 license should be a valid SPDX license expression
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   linux
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64

npm http fetch POST 200 https://registry.npmjs.org/-/npm/v1/security/audits/quick 814ms
npm timing audit body Completed in 13ms
audited 14538 packages in 4.438s
found 1018 vulnerabilities (203 low, 807 moderate, 6 high, 2 critical)
  run `npm audit fix` to fix them, or `npm audit` for details
npm verb exit [ 0, true ]
npm timing npm Completed in 4684ms
npm info ok 
npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'run',
npm verb cli   'compile' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb run-script [ 'precompile', 'compile', 'postcompile' ]
npm info lifecycle poa-parity-bridge-contracts@1.0.0~precompile: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~compile: poa-parity-bridge-contracts@1.0.0

> poa-parity-bridge-contracts@1.0.0 compile /home/lorune/bridge-ui/submodules/poa-bridge-contracts
> truffle compile

npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: unsafe-perm in lifecycle true
npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: PATH: /snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.bin:/snap/node/1738/bin:/snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/node_modules/.bin:/snap/node/1738/bin:/snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/node_modules/.bin:/snap/node/1738/bin:/home/lorune/.local/bin/:/home/lorune/Documents/aws-tools:/home/lorune/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: CWD: /home/lorune/bridge-ui/submodules/poa-bridge-contracts
npm info lifecycle poa-parity-bridge-contracts@1.0.0~postcompile: poa-parity-bridge-contracts@1.0.0
npm verb exit [ 0, true ]
npm timing npm Completed in 2004ms
npm info ok 
npm verb lifecycle bridge@0.1.0~compile:contracts: unsafe-perm in lifecycle true
npm verb lifecycle bridge@0.1.0~compile:contracts: PATH: /snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/node_modules/.bin:/snap/node/1738/bin:/snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/node_modules/.bin:/snap/node/1738/bin:/home/lorune/.local/bin/:/home/lorune/Documents/aws-tools:/home/lorune/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
npm verb lifecycle bridge@0.1.0~compile:contracts: CWD: /home/lorune/bridge-ui
npm info lifecycle bridge@0.1.0~postcompile:contracts: bridge@0.1.0
npm verb exit [ 0, true ]
npm timing npm Completed in 6965ms
npm info ok 
npm verb lifecycle bridge@0.1.0~postinstall: unsafe-perm in lifecycle true
npm verb lifecycle bridge@0.1.0~postinstall: PATH: /snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/node_modules/.bin:/snap/node/1738/bin:/home/lorune/.local/bin/:/home/lorune/Documents/aws-tools:/home/lorune/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
npm verb lifecycle bridge@0.1.0~postinstall: CWD: /home/lorune/bridge-ui
npm timing audit submit Completed in 1339ms
npm http fetch POST 200 https://registry.npmjs.org/-/npm/v1/security/audits/quick 1340ms
npm timing audit body Completed in 2ms
npm info lifecycle bridge@0.1.0~prepublish: bridge@0.1.0
npm info lifecycle bridge@0.1.0~prepare: bridge@0.1.0
npm timing stage:runTopLevelLifecycles Completed in 16482ms
npm verb saving []
npm verb shrinkwrap skipping write for package.json because there were no changes.
npm info lifecycle undefined~preshrinkwrap: undefined
npm info lifecycle undefined~shrinkwrap: undefined
npm verb shrinkwrap skipping write for package-lock.json because there were no changes.
npm info lifecycle undefined~postshrinkwrap: undefined
npm WARN ts-pnp@1.0.1 requires a peer of typescript@* but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/react-scripts/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   linux
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   linux
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64

audited 138167 packages in 17.806s
found 66 vulnerabilities (63 low, 3 high)
  run `npm audit fix` to fix them, or `npm audit` for details
npm verb exit [ 0, true ]
npm timing npm Completed in 18187ms

npm install in poabridge contracts folder result :

 lorune@lorune  ~/bridge-ui/submodules/poa-bridge-contracts  ➦ 4615162  npm install --loglevel verbose  
npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'install',
npm verb cli   '--loglevel',
npm verb cli   'verbose' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb npm-session 2d2803dec1d87204
npm info lifecycle poa-parity-bridge-contracts@1.0.0~preinstall: poa-parity-bridge-contracts@1.0.0
npm timing stage:loadCurrentTree Completed in 1336ms
npm timing stage:loadIdealTree:cloneCurrentTree Completed in 9ms
npm timing stage:loadIdealTree:loadShrinkwrap Completed in 681ms
npm timing stage:loadIdealTree:loadAllDepsIntoIdealTree Completed in 943ms
npm timing stage:loadIdealTree Completed in 1987ms
npm timing stage:generateActionsToTake Completed in 73ms
npm verb correctMkdir /home/lorune/.npm/_locks correctMkdir not in flight; initializing
npm verb lock using /home/lorune/.npm/_locks/staging-31a7e66af199bf61.lock for /home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.staging
npm timing audit compress Completed in 109ms
npm info audit Submitting payload of 53330bytes
npm timing action:extract Completed in 315ms
npm timing action:finalize Completed in 53ms
npm timing action:refresh-package-json Completed in 84ms
npm timing action:preinstall Completed in 0ms
npm timing action:build Completed in 1ms
npm timing action:install Completed in 1ms
npm timing action:postinstall Completed in 1ms
npm verb unlock done using /home/lorune/.npm/_locks/staging-31a7e66af199bf61.lock for /home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.staging
npm timing stage:executeActions Completed in 479ms
npm timing stage:rollbackFailedOptional Completed in 61ms
npm info linkStuff poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~install: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~postinstall: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~prepublish: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~prepare: poa-parity-bridge-contracts@1.0.0
npm timing stage:runTopLevelLifecycles Completed in 4230ms
npm verb saving []
npm verb shrinkwrap skipping write for package.json because there were no changes.
npm info lifecycle undefined~preshrinkwrap: undefined
npm info lifecycle undefined~shrinkwrap: undefined
npm verb shrinkwrap skipping write for package-lock.json because there were no changes.
npm info lifecycle undefined~postshrinkwrap: undefined
npm WARN webpack-cli@2.0.13 requires a peer of webpack@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN poa-parity-bridge-contracts@1.0.0 No repository field.
npm WARN poa-parity-bridge-contracts@1.0.0 license should be a valid SPDX license expression
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   linux
npm verb notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64

npm timing audit submit Completed in 1285ms
npm http fetch POST 200 https://registry.npmjs.org/-/npm/v1/security/audits/quick 1590ms
npm timing audit body Completed in 313ms
audited 14538 packages in 5.4s
found 1018 vulnerabilities (203 low, 807 moderate, 6 high, 2 critical)
  run `npm audit fix` to fix them, or `npm audit` for details
npm verb exit [ 0, true ]
npm timing npm Completed in 5625ms
npm info ok 

npm run compile results :

npm info it worked if it ends with ok
npm verb cli [ '/snap/node/1738/bin/node',
npm verb cli   '/snap/node/1738/bin/npm',
npm verb cli   'run',
npm verb cli   'compile',
npm verb cli   '--loglevel',
npm verb cli   'verbose',
npm verb cli   '--scripts-prepend-node-path' ]
npm info using npm@6.4.1
npm info using node@v8.15.1
npm verb run-script [ 'precompile', 'compile', 'postcompile' ]
npm info lifecycle poa-parity-bridge-contracts@1.0.0~precompile: poa-parity-bridge-contracts@1.0.0
npm info lifecycle poa-parity-bridge-contracts@1.0.0~compile: poa-parity-bridge-contracts@1.0.0

> poa-parity-bridge-contracts@1.0.0 compile /home/lorune/bridge-ui/submodules/poa-bridge-contracts
> truffle compile

npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: unsafe-perm in lifecycle true
npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: PATH: /snap/node/1738/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/lorune/bridge-ui/submodules/poa-bridge-contracts/node_modules/.bin:/snap/node/1738/bin:/home/lorune/.local/bin/:/home/lorune/Documents/aws-tools:/home/lorune/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
npm verb lifecycle poa-parity-bridge-contracts@1.0.0~compile: CWD: /home/lorune/bridge-ui/submodules/poa-bridge-contracts
npm info lifecycle poa-parity-bridge-contracts@1.0.0~postcompile: poa-parity-bridge-contracts@1.0.0
npm verb exit [ 0, true ]
npm timing npm Completed in 2040ms
npm info ok 

Same problem when running the npm run start with a different file missing this time :

Failed to compile

./src/stores/utils/bridgeMode.jsModule not found: Can't resolve '../../contracts/ForeignBridgeErcToErc.json' in '/home/lorune/bridge-ui/src/stores/utils'
0 Likes

#7

Just as remark the correct folder it should refer to where the json file is is …/…/contracts/upgradeable_contracts/erc20_to_erc20/ that location holds the foreignbridgeerctoerc json file

0 Likes

#8

does it mean that you didn’t get any error when performed: cp -r submodules/poa-bridge-contracts/build/contracts src/contracts? If so, could provide the output of the command find submodules/poa-bridge-contracts/build/contracts?

Then could you provide full output of all steps starting from very beginning - from cloning the Bridge UI repo:

  1. git clone https://github.com/poanetwork/bridge-ui.git
  2. cd bridge-ui
  3. git submodule update --init --recursive --remote
  4. ls -l submodules/poa-bridge-contracts
  5. npm install --loglevel verbose
  6. find submodules/poa-bridge-contracts/build/contracts
  7. find src/contracts
0 Likes

#9

I don’t remember seeing any errors, i lost the console history for it.

the output for the find command :

lorune@lorune  ~/bridge-ui   master ●  find submodules/poa-bridge-contracts/build/contracts
submodules/poa-bridge-contracts/build/contracts
submodules/poa-bridge-contracts/build/contracts/Ownable.json
submodules/poa-bridge-contracts/build/contracts/UpgradeabilityProxy.json
submodules/poa-bridge-contracts/build/contracts/EternalStorageProxy.json
submodules/poa-bridge-contracts/build/contracts/Validatable.json
submodules/poa-bridge-contracts/build/contracts/ForeignBridgeNativeToErc.json
submodules/poa-bridge-contracts/build/contracts/ERC677BridgeToken.json
submodules/poa-bridge-contracts/build/contracts/BasicToken.json
submodules/poa-bridge-contracts/build/contracts/UpgradeabilityStorage.json
submodules/poa-bridge-contracts/build/contracts/Proxy.json
submodules/poa-bridge-contracts/build/contracts/ERC20Basic.json
submodules/poa-bridge-contracts/build/contracts/Message.json
submodules/poa-bridge-contracts/build/contracts/UpgradeabilityOwnerStorage.json
submodules/poa-bridge-contracts/build/contracts/MintableToken.json
submodules/poa-bridge-contracts/build/contracts/BurnableToken.json
submodules/poa-bridge-contracts/build/contracts/ERC20.json
submodules/poa-bridge-contracts/build/contracts/IBlockReward.json
submodules/poa-bridge-contracts/build/contracts/IOwnedUpgradeabilityProxy.json
submodules/poa-bridge-contracts/build/contracts/BasicHomeBridge.json
submodules/poa-bridge-contracts/build/contracts/IBridgeValidators.json
submodules/poa-bridge-contracts/build/contracts/HomeBridgeErcToErc.json
submodules/poa-bridge-contracts/build/contracts/OwnedUpgradeability.json
submodules/poa-bridge-contracts/build/contracts/Sacrifice.json
submodules/poa-bridge-contracts/build/contracts/ERC677.json
submodules/poa-bridge-contracts/build/contracts/ForeignBridgeErcToNative.json
submodules/poa-bridge-contracts/build/contracts/SafeMath.json
submodules/poa-bridge-contracts/build/contracts/IBurnableMintableERC677Token.json
submodules/poa-bridge-contracts/build/contracts/HomeBridgeNativeToErc.json
submodules/poa-bridge-contracts/build/contracts/OverdrawManagement.json
submodules/poa-bridge-contracts/build/contracts/EternalStorage.json
submodules/poa-bridge-contracts/build/contracts/ERC677Receiver.json
submodules/poa-bridge-contracts/build/contracts/BasicForeignBridge.json
submodules/poa-bridge-contracts/build/contracts/HomeBridgeErcToNative.json
submodules/poa-bridge-contracts/build/contracts/BasicBridge.json
submodules/poa-bridge-contracts/build/contracts/BridgeValidators.json
submodules/poa-bridge-contracts/build/contracts/StandardToken.json
submodules/poa-bridge-contracts/build/contracts/OwnedUpgradeabilityProxy.json
submodules/poa-bridge-contracts/build/contracts/ForeignBridgeErcToErc.json
submodules/poa-bridge-contracts/build/contracts/DetailedERC20.json
submodules/poa-bridge-contracts/build/contracts/ERC677Bridge.json
submodules/poa-bridge-contracts/build/contracts/Migrations.json
submodules/poa-bridge-contracts/build/contracts/BlockReward.json

The output of the remaining commands i put in a text file, due to the size (871kb) and its only possible to upload images on this forum, i put it on a private server the file is located at : http://www.terence.nl/bridge-ui.txt

Once all those were done, i added my .env file to the folder, and tried running it again and were back to the original error :

Thanks in advance for the help already so far, this part is a mystery i had less issues getting the bridge itself up and running :slight_smile:

0 Likes

#10

Thanks a lot. Now I see the issue.
Please use git submodule update --init --recursive without --remote. We updated the documentation with this info both in the repo and in the forum on last Friday.

2 Likes

#11

Great that fixed the problem, thanks a bunch for the help !

1 Like