POA Forum

Increase block gas limit on Kovan to 12.5M

Dear @kovan-validators,

Recently, Ethereum Mainnet miners increased block gas limit up to 12.5M gas/block (https://ethstats.net/). To keep smart contracts functionality of Kovan compatible with ETH, we propose to increase block gas limits in Kovan as well.

You can follow these steps to update the limit on your Kovan validator node.

  1. Connect to your Kovan validator node.

  2. Create a backup copy of current version of parity config

sudo cp -a /home/validator/node.toml /home/validator/node.toml.bkp
  1. Check that backup is created
ls /home/validator

you should see node.toml.bkp in the list.

  1. Open config file in your favorite text editor (I use nano here as an example)
sudo nano /home/validator/node.toml
  1. Look for gas_floor_target configuration option, it should be in the mining section of the file:
...
[mining]
...
gas_floor_target = "10000000"
...
  1. Change the value from "10000000" to "12500000"

  2. Save the file and exit (in nano: press CTRL+X and confirm YENTER)

  3. Restart parity service and netstat agent

sudo systemctl restart poa-parity && sleep 10 && sudo systemctl restart poa-netstats 
  1. Check in netstats (https://kovan-netstat.poa.network) that your node is “green” and in sync with others.

  2. In case something goes wrong you should be able to rollback by restoring original configuration file from the backup

sudo cp -a /home/validator/node.toml.bkp /home/validator/node.toml
sudo systemctl restart poa-parity && sleep 10 && sudo systemctl restart poa-netstats 

Also, noticed that POA Network (@igorbarinov) and Provide (@kthomas) nodes are not working at the moment.

Lab10 (@d10r @mteufelberger @tze42), your Kovan node is not working ATM. Please, check and restart it

Done by @mteufelberger

1 Like