Forum

Internal JSON-RPC error

I tried to bridge my assets from erc20 through xDai to BSC
transaction hash:

0x301504563c199831ac0c65e1ed04221f407b65bf927240fae8d6d0899232dfff

But in the history tab while clicking the Claim button in the bottom of the page it shows a message saying: Internal JSON-RPC error
also I can see my sending Tx but not my receiving Tx
what can I do to claim my assets?

Tokens should be already in your wallet. (May need to add contract address manually on BSC side: 0x1d1eb8e8293222e1a29d2c0e4ce6c0acfd89aaac)

sorry for being noob
but how to add the address to my wallet?

Are you talking about this tx: Binance Transaction Hash (Txhash) Details | BscScan?

If so, it means that your transfer has been executed successfully and the tokens are on your balance. The issue with the JSON-RPC error is because you are trying to execute the transfer one more time.

It can be done directly from the OB UI by pressing the fox icon:

right now i’m stuck here
i can see the funds in the Omnibridge page but not in my xDai or BSC wallet

Click on the link in the “Sending Tx” column and check the status of the transfer.

Thanks!
problem solved after i manually add token address into metamask
:+1:

1 Like