Issues setting up test xDai chain - seems like no blocks are being produced

support

#1

Hi POA Community!

At Maker we are in the process of setting up a test xDai chain, bridged to Kovan, using this guide: https://github.com/poanetwork/wiki/wiki/How-to-launch-POA-Network-bridged-to-stable-ERC20-coin to carry out some scalability experiments (Setup high tps test xDai chain).

I have deployed the nodes and the network on AWS using the deployment scripts, I have however run into a few issues - namely from step 6 and onwards.

Step 6
When I try to connect to our network in MEW I get a connection error:
(error_33) Could not connect to the node. Refresh your page, try a different node (top-right corner), check your firewall settings. If custom node, check your configs.

When I use Parity RPC calls I can however see that there is a live network.
Consequently I tried to use Seth (from dapp.tools) to execute the contract functions from command line instead, but the transactions are just idle. It seems that no blocks are being produced - the transactions are published, but never mined, so the chain seems idle. Therefore I tried to use RPC calls to see the latest blocks - the latest block is from 1970, so I have a feeling no block are being produced when submitting transactions.

Despite this I carried on.

Step 11
When trying to deploy the bridge contracts using the latest from develop branch as suggested and the .env file from the readme, it fails with:


Bridge mode: ERC_TO_NATIVE

deploying storage for home validators

TypeError: Cannot read property 'length' of undefined

    at sendNodeRequest (/xxx/xxx/poa-bridge-contracts/deploy/src/deploymentUtils.js:113:36)

    at <anonymous>

    at process._tickCallback (internal/process/next_tick.js:189:7)

Error: TypeError: Cannot read property 'status' of undefined

    at deployContract (/xxx/xxx/poa-bridge-contracts/deploy/src/deploymentUtils.js:49:32)

    at <anonymous>

    at process._tickCallback (internal/process/next_tick.js:189:7)

I checked out the commit from Nov 28th (when the wiki page was last edited) and used the .env file format from the wiki and then it just sits at

BRIDGE_MODE=ERC_TO_NATIVE

pending txHash 0x6a4ba9f7057bfea53fec24d5b293b2b2ef2ae258887f3412082621cf5bbdcc57

with nothing happening. Again, I suspect this might be due to blocks not being produced.

Does anyone have any idea what the issue might be? Any pointers would be helpful. I suspect there is something wrong with the network since I cannot connect through MEW, or that no blocks are being produced.


#2

I’d be happy to lend a hand testing and troubleshooting later in the week - perhaps Wednesday evening or Thursday a.m. GMT -6. Feel free to send me a dm here on the forum with best time to connect.

Jim


#3

Hi Jim,
do you have experience in setting up a bridged network like xDai?


#4

Hi, guys. The problem (I’m almost sure) with MEW is in default forbid for insecure scripts. Please, allow them when using your custom network.


#5

Regarding the step 11th - make sure you have at least some coins on foreign side. Otherwise, this error will be thrown again.


#6

@ArseniiPetrovich The insecure scripts step fixed our issue in step 6. For step 11 we still get the same error. By coins you mean having ETH on the Kovan validators right?


#7

@lollike To Validators and to Deployment account also. Once deployment is complete - transfer funds from deployment account to the validators, the deployment account will not need them anymore.


#8

The error persists with K-ETH on all accounts.


#9

Hm. We’ve just noticed, that you have used the develop branch, that is specified in the instruction. However, the essential patch for xDAI network was already merged from develop to master branch. We will rewrite the instruction, but for now, please, try the master branch instead.


#10

Hi! Which url are you using as HOME_RPC_URL in your .env file in the step 11? The error I see could be caused that the node you are referring to does not respond correctly on the RPC calls the deployment script produces.