Forum

Moving from xDai to Dai using a burner wallet (xdai.io)

I got some dai and used the burner wallet to change dai into xdai. This went smoothly. Put it on honeyswap and made trades. When I decided to cash out of my trades I sold honey (HNY) into xdai. I than went to the xdai.io and tried to convert xdai to dai. Except it never came out. Now my money in dai is apart of some external storage proxy (0x730-ebaa6). I don’t know what this is. However, when I look at my metamask activity it shows a contract interaction and the amount that is the exact amount I’m missing. When I search the address it looks like some general wallet for transactions or something as there are many transactions in there that are not mine. I have dai that I don’t know where it is or how to get it. All I did was try to convert back from xdai to dai using the xdai.op bridge so I could move it off the xdai chain. Can someone help?

txn: 0xa08557250385a1dab7d7416060733a2ad08c5aa1f0fc68926aac35a00d24ffae

If you are using MetaMask, after you have bridged your xDai back to DAI, make sure to change your Network selection back to Ethereuem blockchain. Once you have selected the correct blockchain your DAI balance should appear in MetaMask display. Good luck!

I am having the same problems, I am also switched backed the the Ethereum Main-net
Here is txn hash 0xeb02a453465dc6a9c2cc37ecc134fe0839fd941ffe023780cf529fdcbf122827

can someone help ? Use the burner to switch Xdai to Dai but never got Dai
My money also went to external proxy 0x7301CFA0e1756B71869E93d4e4Dca5c7d0eb0AA6

Nah my xDai to Dai never appeared in dai on the burner here is a pic: The 1361.84 went to that proxy address.

Yea the same here …I use the burner from xDai to Dai
Never received any Dai
It’s in some proxy Wallet

same issue here, still waiting

@1proof, @akolotov So what is this proxy wallet and how do I get my funds from it?

txn number: 0xa08557250385a1dab7d7416060733a2ad08c5aa1f0fc68926aac35a00d24ffae

@Neuron @Frankdematro @Bishop

Did you read this message on the forum: Important changes in a user interaction with the xDai bridge?

We have changed behavior of the bridge and users now must finialize the requests they made to withdraw xDai. It means that the process consist now from two steps:

  1. initiate the withdrawal by sending a transaction in the xDai chain
  2. finalize the withdrawal by sending a transaction to the Ethereum Mainnet

The only app supporting this behavior is https://bridge.xdaichain.com. You can use this app after reading the following manual: https://www.xdaichain.com/for-users/converting-xdai-via-bridge/moving-xdai-to-dai.

Neither xdai.io nor xmoon.exchange does support the changes. DO NOT USE THEM until they start supporting the new process.

So, since you already initiated the withdrawal of xDai, you need to finalize it. For this, go to https://bridge.xdaichain.com, switch MM to the Ethereum Mainnet and press the link “Havn’t received your token?”.

image

Next, you will be prompted for the transaction hash initiating the withdrawal, you can find it in MM or the BlockScout. Here is a page that could help you to find the hash: https://www.xdaichain.com/for-users/converting-xdai-via-bridge/find-a-transaction-hash.

If you have any issues please let me know.

2 Likes

HOLLY S**T. IT WORKED. Thank you.

3 Likes