xDai and POA Forum

POA20 not received from POA TokenBridge

Hello

I was using bridge poa net to transfer POA to POA20

However something happened with one transaction: https://blockscout.com/poa/core/tx/0xab64e58dad21007243f6eeb3fd3315dc0becd1e1a7e0ecf25408892cb1918e3f/internal_transactions

No POA20 received to ETH network (you can check it here https://etherscan.io/token/0x6758b7d441a9739b98552b373703d8d3d14f9e62?a=0x0000000000000000000000000000000000000000)

After TX signed from it was stuck at the very last step of UI (“Validators confirming”) for > 8h and I had to reload screen so lost it’s status on UI

Could you please help understand me where it is? Because according to transaction details at blockscout it’s has ‘Success’ status however no respective amount of POA20 at ETH mainnet neither POA returned in POA core

Thanks

Current eventStats shows unprocessed events:

  "onlyInHomeDeposits": [
    {
      "transactionHash": "0xab64e58dad21007243f6eeb3fd3315dc0becd1e1a7e0ecf25408892cb1918e3f",
      "blockNumber": 15394667,
      "referenceTx": "0xab64e58dad21007243f6eeb3fd3315dc0becd1e1a7e0ecf25408892cb1918e3f",
      "recipient": "0xA6256dE4c5Ff4037c7F3952B3Eb6f66F4b94e2E2",
      "value": "49950000000000000000000"
    }
  ],
  "onlyInForeignDeposits": [],
  "onlyInHomeWithdrawals": [],
  "onlyInForeignWithdrawals": [],
  "lastChecked": 1591124846,
  "ok": false,
  "health": true,
  "timeDiff": 35
} 

Need to ping collected-signatures watcher for 15394667 block. Not sure I’m able to run reset-lastBlock.sh without validator address private key

Thanks for reporting this. The issue with the stuck deposit was fixed. Please double check your balance of POA20 tokens on the Ethereum Mainnet.

1 Like

Thank you, @akolotov, indeed it’s fixed.
Am I able to maintain such stuck deposits by myself (if that happen again) or it’s a matter of having validator private key?

Hello
There is another transaction stuck in onlyInHomeDeposits. Current eventStats:

  "onlyInHomeDeposits": [
    {
      "transactionHash": "0xc31ee86bbc9317300639109c4f2327939ecc8f414cf2ef6e3b4019e6723bdca4",
      "blockNumber": 15751830,
      "referenceTx": "0xc31ee86bbc9317300639109c4f2327939ecc8f414cf2ef6e3b4019e6723bdca4",
      "recipient": "0xA6256dE4c5Ff4037c7F3952B3Eb6f66F4b94e2E2",
      "value": "39960000000000000000000"
    }
  ],
  "onlyInForeignDeposits": [],
  "onlyInHomeWithdrawals": [],
  "onlyInForeignWithdrawals": [],
  "lastChecked": 1592902927,
  "ok": false,
  "health": true,
  "timeDiff": 221
}

@akolotov could you help sort it out, or let me know please how I can do it by myself.

Thank you!

Please check. It should be OK now: https://etherscan.io/tx/0xd95ceea04fd951b904e01450517e2bee9b363ea8d55ca7ef60b56e8c4a0b45a6

The problem was on the JSON RPC node side. It lost one of the transactions from the validator.

Thanks a lot! All good now, yes. :+1: