Problem signing messages with hardware wallets on RSK

Hi, since the last update of Chrome I’ve been facing some errors using hardware wallets on RSK (both Ledger and Trezor) to sign messages from a Gnosis Safe dApp.

This is what I see with Trezor:

Note: the Trezor allow popup asks for ETH derivation instead of RSK

And this is what I see with Ledger:

In both cases, confirmation never gets to the devices (before updating Chrome it did work).
I tried the same with Metamask (using ETH addresses on RSK -and ETH app in case of Ledger-) and it worked.

Can you help us with this? It’s very important the full use of hardware wallets in Nifty.


1 Like

Hi @Alejandro_Cavallero

Could you share a link of Gnosis safe Dapp for RSK chain? I want to reproduce exactly your case. Additionally, is firmware on both hardware wallets up to date?

Hi @viktorbaranov, sure:

Yes, both firmwares are updated

I tried to reproduce the signing issue with Gnosis safe Dapp (from the link you posted above) and Tezor hardware wallet and I had no issues. Here are the details of my test:
Nifty Wallet 5.2.0
Chrome 87.0.4280.67 (Official Build) (x86_64)
Trezor Model T firmware 2.3.4

I’ve created a safe wallet with 2 owners (from Trezor T wallet) and signing policy 2/2. I was able to send funds from Gnosis safe by signing the messages from 2 owners. I saw exactly the same screens, that you posted above, and it didn’t prevent me from signing. If you have absolutely the same versions of components then what is different in my test in comarison to your try is what I sign. In that case, please DM me the details of the message you sign with Nifty + HW (target contract/EOA address, method to call, parameters of the call). After that, I will try to reproduce exactly the same call.

1 Like

My chrome is Versión 87.0.4280.67 (Build oficial) (x86_64) too

Though there is no issue with Trezor, I found an issue with signing messages from Gnosis Safe Dapp with Nifty Wallet + Ledger. I addressed this issue in version 5.2.1 which is released but not published yet. I’ll let you know once it is published.

1 Like

Great @viktorbaranov! And checked, Trezor works ok with last versions as you said

5.2.1 is published in Google Chrome Web store.

It’s solved! awesome as usual @viktorbaranov

1 Like