xDai Stable Chain xDai Stable Chain BlockScout BlockScout TokenBridge TokenBridge

Public Testnet Trusted Setup

Hi guys,
we are ready to start the public network with real validators.

Phase one. Deployment

The boot node is deployed at http://13.90.94.0:3000/

First, you have to ask me for your initial key in private message on the forum and I’ll send it to you.
Second, you have to create your own keys:

Third, deploy your mining node. Deployment instruction for a node https://github.com/oraclesorg/oracles-wiki/blob/master/ceremony.md

Feel free to ask questions here or on GitHub. Please don’t use other forms of communications about the set-up and problems. I, Viktor @viktorbaranov, and Pavel @phahulin will help you.

1 Like

We finished our tests for today. I’ll keep you updated when you can install nodes.

Report:

1)Rename initial_key.txt to initial_key.json
2)Add wording to your github wiki that Oracles Dapp is the key generation app.
I would also probably suggest your to move Whole ceremony section to a different wiki page, so only relevant content stays there

Generation Dapp:
1)Rename Create Keys button to upload your initial key button
2)Gas estimation wasn’t correct and I had to change it manually to 2 gas price in metamask
3)I had 3 metamask popups when I was creating the keys. It’s very bad UX experience, please do it 1 by 1 with according screen instructions on what is going on.
4)Remove Read More links that don’t do anything when keys are generated.
5)Rename each key with their corresponding role. Example:
from: key_34a84c78b61ad2c0214430b2a84d8d096a276ae2 to mining_key_34a84c78b61ad2c0214430b2a84d8d096a276ae2
6)Nice to have: For each password/address have a Copy tooltip similar to metamask Copy Address button. https://www.npmjs.com/package/clipboard - library to use
Azure Wiki:
It’s not clear where do I get netstat server and netstat server key.
Please make sure you provide that information for our mainnet ceremony

1 Like

Every Dapp doesn’t recognize Web3 metamask from the first time, user has to manually refresh the page 2-3 times.

1 Like

when keys are generated, please mention in IMPORTANT box that user also need to COPY and SAVE Passwords.
Don’t let a user close the window if a person didn’t wrote their password.

window.onbeforeunload = function(){
   // Do something
}
// OR
window.addEventListener("beforeunload", function(e){
   // Do something
}, false);

https://github.com/oraclesorg/oracles-wiki/blob/master/ceremony.md deploy to azure button needs to be opened in new tab (target="_blank")

Nice to have:
When you are in Dapp generation key, it would be great if the form fields could be all selected using TAB key.
Right now it only selects the left section when you press tab, skipping the right section. It happens because of invalid HTML format, you have to wrap all input fields inside <form> element.

the current html is:

<div class="create-keys-inputs">
        <div class="left">
        </div>
        <div class="right">
        </div>
      </div> 

just change from div to form and it should work

Suggestion:
I don’t really see why you needed to fork metamask, I think just having instruction on how to add Oracles RPC node should be sufficient in order to have full featured metamask with all updates.

we need forked metamask to detect our network in Metamask. Viktor, @viktorbaranov can we do it if the test network will be specified in as a custom endpoint in the original Metamask?

Yes, we can detect it in such case too.
As a suggestion, maybe to add some words about Oracles dev test network faucet in wiki, as we use original MetaMask for now?

Fixed, thanks for suggestion.

2 Likes

Implemented in dApp.

2 Likes

@viktorbaranov thank you so much for your hard work! You rock!

1 Like

Guys, I’m going to give the noob user test on this experience :slight_smile:

I got stuck here trying to import the initial_key.txt. I figured out on my own to rename extension to .json, though the user shouldn’t have to do that step (good that we fixed that), but I have no idea which password to use for key import. The address in address-pass.txt doesn’t look like a password, and netstats secret didn’t work either.

So MetaMask is expecting a password from me as part of importing the JSON key, and I have no idea where to get one. This user is lots trying to figure out how to open the door into the Oracle network.

Best, Michael

Hello, thanks for your feedback!
Are you using Windows as your operating system?

in your address-pass there should be a password

Figured it out. You guys created the text file on a *nix box, and on Windows the two lines look like one. You need to make the file Windows friendly (you know NL and CR). Opening the txt file in chrome showed two lines, but in Notepad it’s just a single line.

Another issue I ran into is that after importing the account, next step is Ceremony and it says:

“If you have an invitation from Oracles network, you’ll be able to generate your production keys through Ceremony Dapp”

By default MetaMask is still set to the default account, so the Dapp link doesn’t work. Opening it in any other browser doesn’t work either. You expect understanding of how to launch Dapps. Don’t. Tell them explicitly - switch to the newly imported account and then open Dapp in the same tab.

Best, Michael

Ok, next issue. I’ve started the Dapp, entered my info, and uploaded the same initial key I already imported when importing the account. It said: “Adding production keys to Oracles contract…” and then I got:

image

with no instructions of what to do, or any idea why I’m seeing it. Clicking submit doesn’t help. I assume it wants me to send some ETH, but it’s hard coded to 0 ETH.

Instructions didn’t mention this at all:

  1. Open Ceremony Dapp page and follow dapp’s instructions. You’ll get your production keys (mining, payout, voting) at the end of process.

  2. Download keystore files of the generated keys and save paswords for the keys in a safe place.

So what’s next?

Just send transactions. Should be 3. @phahulin please add this to the instruction

2 Likes

The ceremony Dapp is somehow not picking up on which network MetaMask is attached to, because I reload over and over and always get this message even though I have connected to what I believe is the custom RPC - and I believe I am blocked until I can connect to the right network. I even tried installing the forked oracles version of meta mask and still have the same problem:
image