Forum

Python/pip error on network deployment

Hi there!

I am going through the instructions step by step for stablechain network deployment on AWS (Stable Chain Network Deployment - xDai STAKE).

Everything goes smooth until I get to launching the playbook for the netstat server with ansible-playbook -i hosts site.yml

I then get the following error when it gets to TASK [nginx : Install pyOpenSSL]

fatal: [REDACTED]: FAILED! => {"changed": false, "cmd": ["/usr/bin/pip3", "install", "pyOpenSSL"], "msg": "stdout: Collecting pyOpenSSL\n Downloading https://files.pythonhosted.org/packages/b2/5e/06351ede29fd4899782ad335c2e02f1f862a887c20a3541f17c3fa1a3525/pyOpenSSL-20.0.1-py2.py3-none-any.whl (54kB)\nRequirement already satisfied (use --upgrade to upgrade): six>=1.5.2 in /usr/lib/python3/dist-packages (from pyOpenSSL)\nCollecting cryptography>=3.2 (from pyOpenSSL)\n Downloading https://files.pythonhosted.org/packages/fa/2d/2154d8cb773064570f48ec0b60258a4522490fcb115a6c7c9423482ca993/cryptography-3.4.6.tar.gz (546kB)\n Complete output from command python setup.py egg_info:\n \n =============================DEBUG ASSISTANCE==========================\n If you are seeing an error here please try the following to\n successfully install cryptography:\n \n Upgrade to the latest pip and try again. This will fix errors for most\n users. See: https://pip.pypa.io/en/stable/installing/#upgrading-pip\n =============================DEBUG ASSISTANCE==========================\n \n Traceback (most recent call last):\n File \"<string>\", line 1, in <module>\n File \"/tmp/pip-build-q6zijyhe/cryptography/setup.py\", line 14, in <module>\n from setuptools_rust import RustExtension\n ImportError: No module named 'setuptools_rust'\n \n ----------------------------------------\n\n:stderr: Command \"python setup.py egg_info\" failed with error code 1 in /tmp/pip-build-q6zijyhe/cryptography/\nYou are using pip version 8.1.1, however version 21.0.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n"}

I’ve tried various things like trying to update pip and python on the server but haven’t been able to get it to work.

Is anyone able to advise on how to get past this hurdle?

Thanks and keep up the great work!

I think I solved it:

Had to SSH into the netstat server.

Then run: curl https://bootstrap.pypa.io/pip/3.5/get-pip.py -o get-pip.py

Then run: sudo python3 get-pip.py pip==20.3.4

This updated pip systemwide to a version which doesn’t break python3.5.

This is also necessary when you get to the bootnode setup.

Note that I also ran sudo apt-get update and sudo apt-get upgrade on the servers over ssh which may also have helped.