Sale goes live in 7 days..but supply error?


#1

My ICO goes live in 7 days, but when checking the contract address and token address on etherscan I see an error:

“Token totalSupply() method returned a zero value. Is the token contract ERC-20 compliant? Please check with contract creator for more info”

What’s going on here??

Reference:

token address:
https://etherscan.io/token/0x2a352c365B81BAAB9A0Bc07d3751aF489Db8965e

crowsale contract address:
https://etherscan.io/token/0x8b620a74f0106AA54Dbd560e72C7cA854D8B8420


#2

I think I’ve figured it out (verifying)


#3

update: I have verified “safemath”,however:

when verifying CrowdsaleTokenExt , my txt has NO constructor arguments after the ABI !

I attempted to create it with hashex, and I get an error [BOOL]

Totally stumped here, my constructor argument should be in my CrowdsaleTokenExt.txt

help?


#4

verified all contracts save one (3/4)

SafeMathLibExt (verified)
CrowdsaleTokenExt (cannot verify, no constructor arguments)
MintedTokenCappedCrowdsaleExt (verified)
ReservedTokensFinalizeAgent (verified)

So, how do I verify CrowdsaleTokenExt without the constructor argument?

Thanks, anxiously awaiting a reply =P

~Molech


#5

where I’m at now… same as above (cannot verify CrowdsaleTokenExt):

“Sorry! The Compiled Contract ByteCode for ‘CrowdsaleTokenExt’ does NOT match the Contract Creation Code for [0x2a352c365B81BAAB9A0Bc07d3751aF489Db8965e].”

I NEED THE CONSTRUCTOR ARGUMENT For: CrowdsaleTokenExt


#6

Starting to feel like I’m talking to myself here… but… I guess it is the weekend afterall (not how I was planning on spending it though):

I am using the Constructor Argument as shown here:
https://etherscan.io/address/0x2a352c365B81BAAB9A0Bc07d3751aF489Db8965e

I continue to get the error:

“Sorry! The Compiled Contract ByteCode for ‘CrowdsaleTokenExt’ does NOT match the Contract Creation Code for [0x2a352c365B81BAAB9A0Bc07d3751aF489Db8965e].”

I’m done with this for the day- hoping to hear from someone helpful soon…

update: My constructor argument is correct (I know this- because when I went to change it- I got the error: “Error! Invalid constructor arguments provided. Please verify that they are in ABI-encoded format”

I got my constructor argument from the input data where the contract was created:

TX: 0xfabcf9ac0589978e78274fd303c67c7692f1156c3e6b199d0108f0178e798a3a

Constructor Arguments:
00000000000000000000000000000000000000000000000000000000000000c0000000000000000000000000000000000000000000000000000000000000010000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000012000000000000000000000000000000000000000000000000000000000000000100000000000000000000000000000000000000000000001b1ae4d6e2ef50000000000000000000000000000000000000000000000000000000000000000000104b654b4c206f66204b656b697374616e0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000044b654b4c00000000000000000000000000000000000000000000000000000000

…at a loss for ideas


#7

You are right with constructor arguments. Etherscan substitutes those from tx - they are correct. Compiler version and optimized flag should be the same as in your summary files. What values did you use? Could you post the screenshot of filled verification page before you click to Verify button?


#8

sure- I copies the .sol file from CrowdsaleTokenExt


#9

haha- now it worked! weird- did nothing different from yesterday… wow- thanks for your help though =)


#10

Having the same issue. I see in your screenshot that you do not put the colon before “SafeMathLibExt” unlike you are told in the video. This is what you did differently. And this is why it worked for you, and now worked for me as well :slight_smile:


#11

baha- that’s funny, I messed with it for hours while posting about it on here. Saw I had a reply on here when I got up at 4am the next day- so I tried it again to get screen shots… while rubbing the sleep out of my eyes… and THEN it worked… in seconds (while half asleep) =P haha- guess that’s how it goes sometimes! n_n


#12

Dunno if you were following the instructions of the video on how to verify the contract but that was what caused the issue for me.

Video says: “you need a colon, don’t forget to put the colon”. But guess what? You actually don’t have to put a colon if you want it to work. Thankfully you posted that screen and I noticed you didn’t put the colon there and it worked for you.


#13

Yes, Etherscan changed the rules for verification Unable to verify source code: constructor argument missing