Forum

Token cannot be recognized by exchanges

hello, to

i used the Omni bridge to transfer USDC ERC20 to Binance smart chain network. although. it shows up in metamask, non of the exchanges can read my token to make a transaction.

i went to BSC scan , it appears to show a successful transaction. one thing i noticed is that in BSC i see the token , under the pull down, but there are no $$ values attached to it. please , please help. i thought maybe it needed time, its been over 3 days. my wife is very upset at me. i want to have a good Christmas. please help me, thanks so much.

This is a different instance of the USDC compared to one which you can find on BSC (USDC on BSC is a Binance-Peg token, Binance CEX holds the “real” tokens in their custody).
TL DR: you can check if there is any liquidity for this token on some BSC DEX and if there isn’t, you can move it back to ETH mainnet through the same bridge.

Mojmir, thanks for your note. i tried but was not successful, using the same Omni bridge.

i tried also Pancake swap and Anyswap. they cant seem to read any balance on it, it says zero. although i can see the balance on my metamask.

i have tried everything to no avail. i really need these funds back it is my wife’s. any help from you or the customer support would be helpful, thanks so much.

  1. Go here: OmniBridge
  2. Connect your wallet to BSC
  3. Click on the token and then on “Add custom token”
  4. Add the token. In this case: USD Coin on BSC (USDC) Token Tracker | BscScan
  5. Bridge it back

Mojmir,

Good evening , THANK YOU , THANK YOU. IT WORKED!

I will be able to sleep better tonight, and my wife will be happy we have her funds back. LOL

Have fantastic New, Year, cheers.

1 Like