Updated contract doesn't verify on Etherscan

Hi!

I have created a contract for the crowdsale, everything was fine, even the token was showing up on Etherscan.

I have extended the finalize date and now the token has dissapered from Etherscan and the contract doesn’t get verified.

I tried verifying by adding the:
Contract Name
Contract Address
Compiler Version
Source Code
Encoded ABI
SafeMatchLibEth with relevant address (it was the only contract I managed to verify from received contracts, by the way)

and the message I get is:


Note: Contract was created during Txn# [0x2044b7c73fdc315935e12ef7da0ff81aea9a3f1aae64b2ff0c160bbdf74322da]
** Result: Does not match the input creation bytecode found at this address**

Sorry! The Compiled Contract ByteCode for ‘MintedTokenCappedCrowdsaleExt’ does NOT match the Contract Creation Code for [0xF86Ad18397738C076fC644bdebdF7a77e9Ab2fBC].

Contract name(s) found: ‘CrowdsaleExt’ , ‘ERC20’ , ‘ERC20Basic’ , ‘FinalizeAgent’ , ‘FractionalERC20Ext’ , ‘Haltable’ , ‘MintableTokenExt’ , ‘MintedTokenCappedCrowdsaleExt’ , ‘Ownable’ , ‘PricingStrategy’ , ‘SafeMath’ , ‘SafeMathLibExt’ , ‘StandardToken’
Unable to Verify Contract source code.
Tip: The Contract appears to have been compiled with Optimization=NO, but you have set Optimization=Yes for the source code verification.


I have optimization to ON in the contract

It’s the GLOB tokens with the token address:
0xbBCf10D6bc180172d8d352BE5bBCfB814E8f3474

and the crowdsale address:
0xF86Ad18397738C076fC644bdebdF7a77e9Ab2fBC

Now the crowdsale seems very untrusted.

Is there something I’m doing wrong?
Thank you and best regards,
Dimitri

Hi, please check the screenshots in verification guide with your filled verification form. Perhaps, you are doing this mistake: Unable to verify contract.

Hi, thank you for your reply, no I have tried those before I posted to the forum.
It’s really strange. I also tried the ABI from the tx given in the error message (like it was specified in the second video), but didn’t work either.
Really odd

Attach screenshot of filled verification form before you clicked “Verify” button

Please take a look:

Thank you

You made the same mistake as in another post, I gave you link above.

Thank you very much, Viktor!
Yes, i have removed the colon and it worked like a charm.

Best regards,
Dimitri

May I ask another question?

The crowdsale and token contracts are now verified.
The link from the crowdsale contract shows GLOB TOKEN PRE-SALE link, and when I click on it, it goes to the page with 0 addresses. And specifies an error with exlamation mark about TotalSupply returned 0
https://etherscan.io/address/0xF86Ad18397738C076fC644bdebdF7a77e9Ab2fBC

There were a couple small sales made, and it can be seen from the Token contract: https://etherscan.io/address/0xbbcf10d6bc180172d8d352be5bbcfb814e8f3474

But they are not linked.

I have another contract I got with the download from the Wizard named CrowdsaleTokenExt, but it has got no encoded ABI, and I still didn’t find a way to verify it, perhaps there is another trick to it that I don’t know.

And one more thing, the token has 2 addresses which link to the same token and they are
0xbbcf10d6bc180172d8d352be5bbcfb814e8f3474
and
0xbBcf10d6bc180172d8d352be5bbcfb814e8f3474

with just 1 letter difference, but surprisingly it makes no difference at all, it’s another weird thing.

Thank you for your support and help!

Best regards,
Dimitri

Please check FAQ section: https://github.com/poanetwork/token-wizard/wiki/FAQ. If you won’t find an answer for one of your questions, please let me know.

Hi again, thank you, there is a lot of useful information, but I didn’t find the one specified.

How can I verify the token contract that has no encoded ABI?
Thank you.

It was the messgae signature.
Figured it out.
Thank you!

I sent POA from binance to eidoo! but eidoo does not support POA, can I recover them?