Forum

Websocket Configuration Error

I am running an instance on https://jupiter.omlira.com and I am using lets encrypt certificate for SSL. However, the websocket connection doesn’t work. I don’t know where is the problem and I couldn’t find the configuration file for the websocket.

Where is the location of websocket config file? And any reason that might cause my websocket to not work? It doesn’t work both on wss:// and ws://

Did you set up ETHEREUM_JSONRPC_WS_URL env variable for Blocksout application. And are websockets enabled on the archive node side?

The ETHEREUM_JSONRPC_WS_URL env is set as ws://localhost:8546

The node runs on the same machine, and I can connect to the node’s websocket from an external IP by doing ws://HOST_IP:8546 and can query stuff.

Just in case, do you have SOCKET_ROOT environment variable enabled? In your scenario, it shouldn’t be set.

I tried both with SOCKET_ROOT set and not set, still the same result. I wonder if it’s an issue on the websocket configs (regarding the SSL certificate) because before I was using default http version and couldn’t get SSL work, so later I installed lets encrypt and started with SSL but this time I lost the websocket.